Edgewall Software
Modify

Opened 10 years ago

Closed 9 years ago

#458 closed defect (duplicate)

build-slave UnicodeEncodeError

Reported by: martin@… Owned by: osimons
Priority: major Milestone:
Component: Build slave Version: 0.6b2
Keywords: Cc:
Operating System: Linux

Description

Hi,

I have a bitten-slave running on Ubuntu Hardy 8.04.3 LTS running Python 2.5.2. I have a build recipe which includes a pylint section, here is the snippet:

<step id="lint" description="Gather lint report">
    <sh:exec executable="pylint" args="mypackage -f parseable" output="pylint.out"/>
    <python:pylint file="pylint.out"/>
</step>

Part way through the pylint run the bluid-slave encounters an internal error. Here is the Traceback.

[ERROR   ] Internal error in build step 'lint'
Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/Bitten-0.6b2-py2.5.egg/bitten/slave.py", line 327, in _execute_step
    step.execute(recipe.ctxt):
  File "/usr/lib/python2.5/site-packages/Bitten-0.6b2-py2.5.egg/bitten/recipe.py", line 228, in execute
    ctxt.run(self, child.namespace, child.name, child.attr)
  File "/usr/lib/python2.5/site-packages/Bitten-0.6b2-py2.5.egg/bitten/recipe.py", line 106, in run
    function(self, **args)
  File "/usr/lib/python2.5/site-packages/Bitten-0.6b2-py2.5.egg/bitten/build/shtools.py", line 40, in exec_
    output=output, args=args, dir_=dir_)
  File "/usr/lib/python2.5/site-packages/Bitten-0.6b2-py2.5.egg/bitten/build/shtools.py", line 147, in execute
    output_file.write(out + os.linesep)
UnicodeEncodeError: 'ascii' codec can't encode character u'\xa0' in position 9: ordinal not in range(128)
[WARNING ] Stopping build due to failure
[INFO    ] Slave exited at 2009-09-22 21:45:18

Let me know if you require anymore more information.

Regards, Martin.

Attachments (0)

Change History (4)

comment:1 Changed 9 years ago by osimons

Could you try the patch that has just been attached to #533?

comment:2 Changed 9 years ago by confluence

This appears to be a duplicate of #504, and the patch from that ticket was committed.

comment:3 Changed 9 years ago by osimons

  • Owner set to osimons

Could this be verified by original reporter? Could you please update to latest from repository, and see if you still get the error?

comment:4 Changed 9 years ago by osimons

  • Milestone 0.6.1 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

No feedback. Presume this is fixed then (ie. duplicate).

Add Comment

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain osimons.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.