Edgewall Software
Modify

Opened 14 years ago

Closed 12 years ago

#221 closed defect (duplicate)

bitten-slave fails on solaris with Python 2.3

Reported by: anonymous Owned by: cmlenz
Priority: critical Milestone: 0.6
Component: Build slave Version: 0.5.3
Keywords: Cc:
Operating System: Other

Description (last modified by dfraser)

bitten-slave fails to run on solaris. Details follow:

Python: Python 2.3.5 (#1, Nov 30 2005, 10:43:01) [C] on sunos5
uname: SunOS HOSTNAME 5.11 snv_67 i86pc i386 i86pc

Running bitten-slave -h results in:

Traceback (most recent call last):
  File "/opt/csw/bin/bitten-slave", line 7, in ?
    sys.exit(
  File "/opt/csw/lib/python2.3/site-packages/pkg_resources.py", line 236, in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
  File "/opt/csw/lib/python2.3/site-packages/pkg_resources.py", line 2097, in load_entry_point
    return ep.load()
  File "/opt/csw/lib/python2.3/site-packages/pkg_resources.py", line 1830, in load
    entry = __import__(self.module_name, globals(),globals(), ['__name__'])
  File "/opt/csw/lib/python2.3/site-packages/Bitten-0.6dev_r517-py2.3.egg/bitten/slave.py", line 39, in ?
    class SaneHTTPErrorProcessor(urllib2.HTTPErrorProcessor):
AttributeError: 'module' object has no attribute 'HTTPErrorProcessor'

Note: similar to #178, but different error.

Marked as duplicate of #163

Attachments (0)

Change History (3)

comment:1 Changed 14 years ago by anonymous

The problem is your python version, which doesn't have that class. Try upgrading to a more recent version of Python.

comment:2 Changed 12 years ago by Remy Blank <remy.blank@…>

This is a duplicate of #163.

comment:3 Changed 12 years ago by dfraser

  • Description modified (diff)
  • Resolution set to duplicate
  • Status changed from new to closed
  • Summary changed from bitten-slave fails on solaris to bitten-slave fails on solaris with Python 2.3

Add Comment

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain cmlenz.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.