Edgewall Software
Modify

Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#378 closed defect (invalid)

Error 500 when view a build report (outdated plugin)

Reported by: Xie Yanbo <xieyanbo@…> Owned by: cmlenz
Priority: critical Milestone: 0.6
Component: General Version: dev
Keywords: Cc:
Operating System: Linux

Description

How to Reproduce

While viewing any build report, /build/name/5076 for example, Trac issued an internal error.

Request parameters:

{'config': u'name', 'id': u'5076'}

User Agent was: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.8) Gecko/2009032608 Firefox/3.0.8 Ubiquity/0.1.4

System Information

Trac 0.11.2
Python 2.5.1 (r251:54863, Feb 13 2008, 20:47:57)
[GCC 4.1.1 (Gentoo 4.1.1)]
setuptools 0.6c7
SQLite 3.3.5
pysqlite 2.4.1
Genshi 0.5.1
mod_python 3.3.1
Pygments 0.10
Subversion 1.4.6 (r28521)
jQuery: 1.2.6

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/trac/web/main.py", line 432, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.5/site-packages/trac/web/main.py", line 204, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib/python2.5/site-packages/Bitten-0.6dev_r619-py2.5.egg/bitten/web_ui.py", line 448, in process_request
    step)
  File "/usr/lib/python2.5/site-packages/Bitten-0.6dev_r619-py2.5.egg/bitten/web_ui.py", line 571, in _render_reports
    step, report.category)
ValueError: too many values to unpack

Attachments (0)

Change History (2)

comment:1 Changed 12 years ago by dfraser

  • Resolution set to invalid
  • Status changed from new to closed
  • Summary changed from Error 500 when view a build report to Error 500 when view a build report (outdated plugin)

OK, so one of your report summarizers is returning more than what the IReportSummarizer API defines for render_summary: a tuple of template filename and data.

Both of the included summarizers (coverage and testing) can only return that tuple correctly.

So the only logical deduction is that you have another plugin installed that includes a summarizer doesn't conform to the API.

This API was changed in [567] (with the merge of the 0.11 branch) - previously summarizers just returned HTML. So you probably have a plugin installed that generates a summary, but hasn't been updated for the 0.11 branch.

If you disable all your plugins and re-enable one by one you should be able to see which one this is.

I'll mark this as invalid since it's basically a plugin that needs upgrading - please feel free to ask further questions if you're struggling to get this fixed though... and thanks for the report!

comment:2 Changed 12 years ago by Xie Yanbo <xieyanbo@…>

You’re right, the build report works well after Eat Lint?-1.0 disabled. Thanks for your advise!

Add Comment

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain cmlenz.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.