Edgewall Software
Modify

Opened 14 years ago

Closed 12 years ago

Last modified 10 years ago

#242 closed defect (worksforme)

Empty build status page

Reported by: jeberger@… Owned by: cmlenz
Priority: major Milestone:
Component: Trac plugin Version: 0.5.3
Keywords: Cc:
Operating System: Linux

Description

Problem description

If you create a build configuration with the following recipe, then the corresponding build status page is completely empty.

<build xmlns:sh="http://bitten.cmlenz.net/tools/sh">

  <step id="bug" description="Shows a Bitten bug">
    <sh:exec executable="echo" args="-I../.."/>
  </step>

</build>

The issue apparently comes from lines 513-514 of trunk/bitten/web_ui.py since removing them (as does the attached patch) fixes the problem (however, since I have no idea what those lines are supposed to do in the first place, I can't tell what side effects this may have).

Attachments (1)

bitten-fix-empty-log-page.patch (689 bytes) - added by jeberger@… 14 years ago.
Patch against trunk revision 519

Download all attachments as: .zip

Change History (4)

Changed 14 years ago by jeberger@…

Patch against trunk revision 519

comment:1 follow-up: Changed 12 years ago by osimons

  • Keywords needinfo added

I can't reproduce this. That recipe builds fine on latest 0.6dev (trunk) as far as I can see. Is this still an issue or can this ticket be closed?

comment:2 in reply to: ↑ 1 Changed 12 years ago by jeberger@…

Replying to osimons:

I can't reproduce this. That recipe builds fine on latest 0.6dev (trunk) as far as I can see. Is this still an issue or can this ticket be closed?

Confirmed: I can't reproduce it with the latest trunk either. I think this ticket can be closed.

comment:3 Changed 12 years ago by osimons

  • Keywords needinfo removed
  • Milestone 0.6 deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Oki. Closing.

Add Comment

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain cmlenz.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.